Registry Services

Registry Services / Recently Commented

2021 Domain Name Year In Review

Is it really 2022? Is it? Although many might view 2021 as another "lost" year due to the pandemic, filled with Zoom™ meetings, virtual conferences, working from home and restricted travel - there were a number of notable domain name stories which deserve to be highlighted. So, without further ado, here are the top 10 biggest domain name stories of 2021 - let's go! more

Industry Insights: RDAP Becomes Internet Standard

Earlier this year, the Internet Engineering Task Force’s (IETF’s) Internet Engineering Steering Group (IESG) announced that several Proposed Standards related to the Registration Data Access Protocol (RDAP), including three that I co-authored, were being promoted to the prestigious designation of Internet Standard. Initially accepted as proposed standards six years ago, RFC 7480, RFC 7481, RFC 9082 and RFC 9083 now comprise the new Standard 95. RDAP allows users to access domain registration data and could one day replace its predecessor the WHOIS protocol. more

Industry Updates

The Domain Industry’s Next Growth Phase Is About Value, Not Volume

Registration Opens for the 2026 .US Town Hall Featuring Internet Policy Pioneer Karen Rose

Young Entrepreneurs Are Delaying Domain Adoption, Not Abandoning It

Applying for a TLD Was Just the Beginning - Now Comes the Real Challenge

Radix Announces Radix Deux: 46 Primary Applications in ICANN’s Next gTLD Round

1,600 Applications Later: What’s Next for the New gTLD Round?

Why Nordic Domain Days Has Become a Defining Event for the Domain Industry

Premium Domain Demand Reaches New High in Radix’s H1 2026 Report

DNIB Reports 401.6 Million Domain Name Registrations in Q2 2026

Momentum Builds as the New gTLD Application Window Enters Its Final Weeks

Why Operational Readiness Will Define the Next Generation of TLDs

What Running .CA and .NL Taught Us About Building Better Registry Infrastructure

Making the Most of the 2026 New gTLD Application Round

Premium Domains Surge as Renewals Strengthen in H2 2025

2025 .US Town Hall Registration Open: Explore Industry Trends & Policy Insights